Start a new topic

Negative export check box produced all black film

Negative export check box produced all black film

When I check the box to output as a negative gerber file, the file views correctly in Fabit but will not plot correctly.  The film images as solid black.

Why didn't my file plot as viewed on screen?
Thanks for your post.

If you check that option, FAB 3000 will just place a negative flag in your Gerber file header (something like %IPNEG%).

There could be a variety of reasons, however it would be practically impossible to guess from just a quick forum post.   Does your plotter have a "Preview Option"?  If yes, did it display fine there?

You'll need to save your FAB 3000 Workspace (*.wrk) and submit a support ticket ( ), so we can take a look. 

I will have to find out if the plotter has a preview option.

I did take the same workspace and output it without the negative check box and then manually changed the "IPPOS" to an "IPNEG" and also the "LPD" to an "LPC" and the file plots correctly.

Both files viewed the same but only one plots correctly.

Shouldn't the LPD change to LPC with the NEG box checked?  That seems like the only difference between the files.
FAB 3000 assumes you already have the correct LPC/LPD options (i.e. for composite gerbers) set in your Gerber file.  Setting the "Neg" flag during export will ONLY add the IPNEG flag to your Gerber header... it won't do anything else to adjust the LPC/LPD options.

Why?  Because not everyone will be sending those gerber files directly to a plotter... 80-90% of our users are Designer's who will probably pass these gerber files down to another person or manufacturer who will then load it into a standard Gerber Viewer or CAM tool (for viewing, quoting, etc).  Since many Gerber viewers and CAM tools ignore the IPNEG flag (during Gerber import), if we also reverse the LPC/LPD options without alerting the user (they would potentially end up with "blank" gerber files being displayed in those other Viewers/CAM tools -- because everything would appear clear without the black outer neg boundary).  I remember back in the day having several customers being upset that they set the "Negative Flag" during export, and their cam guy who is using something like CAM350 complained that the screen was empty.

The easy fix is to simply go to the FAB 3000 Layers table and modify the NEG flag there.  FAB 3000 will adjust the negative flag & adjust the correct LPC/LPD composite options. This way you can actually first view the resulting negative layer before gerber export...  Here's a quick movie showing how easy it is to adjust the Negative Flag and then FAB 3000 will automatically adjust the LPC/LPD composite options:

Thank you very much for your replies to my questions.

The plotter we use does have a viewer and when I modify the neg flag in the layer table and export the file it comes out exactly like we want it.

So bottom line is the neg flag in the export is strictly for viewing purposes and the neg flag in the layer table is the proper way to produce a negative gerber file for plotting.

I will pass this valuable information on to my co-workers and my boss.

Thanks again!
Login or Signup to post a comment