Start a new topic

DXF-to-BMP Fill Problem - Very small 700 nm features do not appear in my bitmap with 166.67 nm resolution. Please help

Customer wrote:

"Pattern 8 large cal layer.dxf" 

Is the full design - about 160 mm square. In this case, the radial rectangles are filled but the crossing rectangles do not show up, except at the 0, 90, 180 and 270 degree locations.

We have created another file using 1 quadrant of the large design. When converted with ACE using the same settings, all rectangles are filled as expected. 

We are not sure if this is an issue trying to fill a 900 nm non-perpendicular rectangle with 166.6667 nm pixels? 

Assistance is appreciated!

After reviewing your new files, this is an issue regarding ultra high resolution and attempting to get a pixel appear within extremely fine tolerances. 

1. For best results, you should design the DXF in "micrometers (um)".  This would let ACE know during import that it has to use it's ultra-fine database tolerances.  Setting to millimeters doesn't alert ACE to the high-tolerances you require and the default database accuracy is 10 (nm).  Scaling DXF to (um) units will immediately increase the database accuracy.

2. If you wish to keep Millimeter design units in DXF, than you must manually instruct ACE to change it's database accuracy.  To change database accuracy, go to menu:  Setup / Preferences..., click tab "Misc.", go to option "Database Accuracy" and choose "1/1000 micron".   If not successful, then try "1/10000 micron" - this is the maximum database accuracy setting for ACE and typically recommended for Linux users. 


Note:  You're attempting to output a final bitmap that is almost 1 trillion pixels (960k X 960k pixels), which I cannot convert and verify on my laptop.  Another great solution is ACE for Linux 64-bit which is optimized to easily output extremely large files (over 1TB).


Best regards,


Customer wrote:



Completed 2 tests overnight:

1.Changed ACE database setting to “1/1000 micron” and converted original drawing with crossed rectangles (your #2 suggestion.)

2.Changed original drawing to use 1 closed polygon in shape of a cross instead of 2 crossed rectangles. Converted with default ACE settings.



Both conversions were successful.



Next test is to change original CAD drawing to use Units = um instead of mm and convert. Will let you know outcome, although there is no reason why there should be any issues.



Going forward, we will do all our designs in um and use the 1/1000 micron setting in ACE.



Thanks for your help!

Login or Signup to post a comment