Start a new topic

DXf Gerber

I imported DXF and got this message below.
I imported Gerber files and got this message, even after rename the
extension from .gbr to .pho
I have the Gerber file converted by ACE3000 previously and the tested DXF
file for comparison. Would you please let me know if I need to set/change
any things in the setup/option?
Thanks a lot

1 Comment

Here's a sample movie tutorial showing how I would convert your DXF to Gerber using FAB 3000:

Note:  To make this work easily I used the DXF import option: "Ignore 0-Width Lines, Arcs".  This tells FAB 3000 to ignore all those hatch lines

My General Observations:

1. I believe the reason you may have had difficulties loading the DXF into FAB 3000, is that the Autoload feature (used in the screen capture only loads Gerber/Drill data, and not DXF).  To load a DXF into FAB 3000, you must use the command (menu: File / Import / DXF).

Here's a quick tutorial (no sound) showing me import your DXF and then compare to the Gerber.

Note:  Here's some other observations.
* The DXF was outputted seems to be scaled in Millimeters (where the gerber was outputted in Inch format).  When using ACE 3000 you have the ability to determine the output units for the DXF (during the DXF export options).

* The "arc" quality looked real bad - see sample photo:
Note:  This can result from low resolution gerber files (make sure to always choose Decimal Digits of 5 or 6).  This allows the gerber to be accurate to 5 or 6 decimal places.

* FAB Layer - Typically you want to turn Fill OFF on FAB layers, because it's just an outline reference to show board outline/drill holes, etc.

* Hatch Lines should be ignored or removed.  In both the DXF and Gerber, there are hatch-lines (at 45 degrees) all throughout the filled boundaries -- which cause excess data and poor edge quality. See both screen captures:

Note:  When possible please do not use Hatch with patterns.  Most CAD tools like AutoCAD don't do a good job showing filled boundaries, so engineers will add hatch lines to help improve visibility, however these hatch lines become excess data when performing the conversion.   We recommend the following:

1. When possible, create the drawing outlines only -- no hatch included.

If the hatch is already in the DXF, and there's nothing you can do; try the following:

A. In ACE 3000 (during DXF Import Options), select the setting to "Ignore Hatch" -- this way ACE ignores the hatch and imports your boundaries.

B. AutoCAD Users can use "SOLID HATCH".  ACE completely understands SOLID Hatch and will import your DXF with the same apperance as the solid hatch.  Keep in mind that you should delete the original entities that were used to create the Solid Hatch (lines, arcs, polylines), because now this is just duplicate data again that you're attempting to convert.

Thanks again, and please let me know if you have any questions.

Best regards,
Login or Signup to post a comment