Start a new topic

How can I improve the results when I convert from Gerber to DXF? I need a DXF file with clean outlines for all gerber geometries.

A common problem when converting gerber files to other CAD formats is that gerber files are generally messy (ie. contain overlapping objects, use multiple line strokes to fill in metal areas, etc) that can cause poor results in the final translated file.

ACE has the ability to "clean-up" these messy gerber files using its editing command "Merge Overlapping Objects". 

After importing gerber data, and getting to the page "Export Cell and Layers"; try the following:
  1. Press button "Edit CAD Data..." (located in the upper right area of ACE or below the Top Cell export tree).  Note: This takes you into the ACE CAD editor, which allows you to modify data before exporting.
  2. Select all objects (goto menu: View | Selection | All...).  Note: You can also place ACE in "Selection Mode" by pressing the selection mode button ("Arrow icon" - second button to the left), and pick a window around your gerber objects.
  3. Go to menu: Tools | Merge Overlapping Objects...  Note: ACE will now convert those messy overlapping gerber files into "clean outline boundaries".  Note: Depending on the size of your gerber files, it may be more effective to clean one layer at a time. To do this goto layers table:  Setup | Layers Table... and turn off all layers, except one.  Then repeat steps 2 & 3.
  4. When you are finished, press button "Back to Conversion Setup", which takes you back to the ACE Conversion setup so you can then export your files.

The feature "Merge Overlapping objects" essentially converts all selected objects to polygons, and then uses it's Boolean engine to calculate the outline of the overlapping objects.  If there are certain objects like circles (i.e. flashes, etc), that you do not want converted to polygons, then please perform the following:

1. Select all objects (except circles or other objects that you do not want merged or converted to polygons).

2. Then run "Merge Overlapping Objects".

Now only the selected items have been merged.

It seems as if I can't upload any attachments Error: Storage limit exceeded. - file size is 429kb and 272kb and both have the extension zip.
Using standard conversion settings I get the attached files ( The problem is shown in withoutMerging.jpg: Objects with overlapping curves. The diamond shaped object is a circle.
Using the method described in this thread I obtain the attached files (
Now the overlapping curves are gone, but the circle has become a polyline (see withMerging.jpg). What can I do to keep the circle as a circle but to merge the other objects?
Login or Signup to post a comment