Start a new topic

Duirng ODB++ import ACE seems to get stuck at 16%. What is it doing?

Duirng ODB++ import ACE seems to get stuck at 16%. What is it doing?
1 Comment

If during ODB++ import ACE seems slow or appears to get stuck, there is only on reason: ODB++ Surfaces.

ODB++ has a complex object called a "surface".  Essentially it is an outer polygon with hundreds (or thousands) of inner islands/holes (clear) and inner metal regions (dark) all of which composes one ODB++ surface. Primarily used for Ground planes.  If the inner boundaries are defined in a clockwise fashion than they are considered islands/holes (which appear clear), if the boundary is counter-clockwise the are metal.  While this proves to be very efficient for Valor's purposes, Gerber doesn't support "surfaces" or those ODB++ "fill" rules, so when ACE converts the ODB++ to gerber (or any other format) it needs to construct regular polygons which Gerber data understands.

Note: The ODB++ surface is similar to a Solid Hatch in AutoCAD.

To speed up the conversion process, please perform the following:
1. Start ACE, and select ODB++ for Import and Gerber for export. (I am assuming you want gerber).
2. Click the ODB++ Import tab "Options",  and for Arc Deviation choose "1.0" 
Note:  The default value is .25 mil, however to speed up the required calculations to convert the ODB++ file a value of at least 0.5 or higher is recommended.
3. Click Next and proceed with the translation as normal.

Note: Please be patient. Depending on the complexity of the ODB++ surfaces, it may take ACE several minutes during ODB++ import to convert the surfaces to polygons.
Login or Signup to post a comment